Windows 10 not outputting to all channels

KeithB

Registered
Thread Starter
Joined
Jan 11, 2022
Messages
3
My AV System  
Preamp, Processor or Receiver
Onkyo TX-sr608
Hello all,
I've looked through the available information here but have not found anything resembling my issue, so here it is.
My AVR is connected to computer via HDMI and it sees 7.1 and I can hear test tones from each speaker when using windows sound settings.
In Rew it will not play individual tones to each speaker, only left and Right mains, I see 8 Channels but still no sound.

Any thoughts?
Thanks
 

Attachments

John Mulcahy

REW Author
Joined
Apr 3, 2017
Messages
5,149
The Windows multichannel test sends usually compressed audio rather than multichannel PCM. Your AVR needs to be in a surround mode that accepts multichannel PCM. A Virtual Audio Cable wouldn't typically be a physical interface, doesn't your HDMI interface appear in the device list (e.g. as Intel Display Audio or similar)?
 

KeithB

Registered
Thread Starter
Joined
Jan 11, 2022
Messages
3
My AV System  
Preamp, Processor or Receiver
Onkyo TX-sr608
My audio receiver appears in the output device list for windows and in REW.
The Windows multichannel test sends usually compressed audio rather than multichannel PCM. Your AVR needs to be in a surround mode that accepts multichannel PCM. A Virtual Audio Cable wouldn't typically be a physical interface, doesn't your HDMI interface appear in the device list (e.g. as Intel Display Audio or similar)?
The Windows multichannel test sends usually compressed audio rather than multichannel PCM. Your AVR needs to be in a surround mode that accepts multichannel PCM. A Virtual Audio Cable wouldn't typically be a physical interface, doesn't your HDMI interface appear in the device list (e.g. as Intel Display Audio or similar)?
Thanks for asking John,
Yes, my receiver appears in the windows sound output list as well as REW but only in Java.
 

Attachments

John Mulcahy

REW Author
Joined
Apr 3, 2017
Messages
5,149
Is it not available for selection in ASIO4All? May want to try FlexASIO instead if it doesn't appear.
 

KeithB

Registered
Thread Starter
Joined
Jan 11, 2022
Messages
3
My AV System  
Preamp, Processor or Receiver
Onkyo TX-sr608
Is it not available for selection in ASIO4All? May want to try FlexASIO instead if it doesn't appear.
Fixed! I had to uninstall the released version of ASIO4ALL and download the Beta version that supports windows 10. After I did that it all came into play.
Hopefully this helps anyone else with this issue.
 
Top Bottom