V5.20.14 early access build

Status
Not open for further replies.

John Mulcahy

REW Author
Thread Starter
Joined
Apr 3, 2017
Messages
7,536
I have tried 2M, 11.9 second sweeps (up from 512k, 3 seconds), but the "Export this sample count:" still offers up to 131,072 and "Place t=0 at sample index:" maxes out at 16,384. Not able to set the center to 131,072 and the output number of samples to 262,144.
Sorry, I assumed you were trying to export the whole IR rather than a sample count. I'll increase the sample count options in the next build. The t=0 sample index can be set to anything up to 1,536,000.

Also, is there a 32-bit float limitation ? REW can read 64-bit float wav files, but doesn't appear to offer 64-float float as an output format.
REW uses 32-bit floats for its internal audio data paths.
 

JoinUs

New Member
Joined
Jan 6, 2023
Messages
73
Content Disappeared


Mic is Umik-1 , And 48k 0-24000hz Sweep.
 
Last edited:

John Mulcahy

REW Author
Thread Starter
Joined
Apr 3, 2017
Messages
7,536
Multiple Messurement (9~12points each Speaker L,R), And then Time Alignment - Vector Avg.
Something Wrong.
The result of Time align for measurements made with a timing reference depends on the measurement delay figures. To comment further you would need to attach the mdat file, splitting it into two files if it is too large. With measurements that have similar impulse responses (e.g. measurements of the same speaker) Cross corr. align will generally do the best job of aligning them with each other.
 

JoinUs

New Member
Joined
Jan 6, 2023
Messages
73
The result of Time align for measurements made with a timing reference depends on the measurement delay figures. To comment further you would need to attach the mdat file, splitting it into two files if it is too large. With measurements that have similar impulse responses (e.g. measurements of the same speaker) Cross corr. align will generally do the best job of aligning them with each other.
Yes, so in this version, I finished using Cross cor. That's why I left a question like this whether there was a slight change in the function of Vector Avg or time align in this beta versions.

This is because I always got a satisfactory vector avg with time align in the 5.19/5.20 full version and months of beta.
The number and spacing of the messages were almost the same, and there was no problematic change. You can use Crosscor but if this isn't a bug I should roll back to the previous version.
 
Last edited:

John Mulcahy

REW Author
Thread Starter
Joined
Apr 3, 2017
Messages
7,536
There hasn't been a change in those features. It is not possible for me to examine the behaviour without having the measurements. If you don't wish to share them that's fine.
 

JoinUs

New Member
Joined
Jan 6, 2023
Messages
73
There hasn't been a change in those features. It is not possible for me to examine the behaviour without having the measurements. If you don't wish to share them that's fine.
No. I did attach file. But it doesn't work. So i upload file on site.
You can see URL
 
Last edited:

John Mulcahy

REW Author
Thread Starter
Joined
Apr 3, 2017
Messages
7,536
I don't see any difference in the behaviour of Time Align in the current build compared to 5.20.13. Perhaps there is more variance in the delay estimation when measurements are made, I will investigate that.
 

sam_adams

Member
Joined
May 23, 2017
Messages
293
You have applied the calibration file for the mic to the sound card.

info2.png


@John Mulcahy, is it possible to place a 'Change Cal' control in the All SPL controls to allow one to change the cal file for all selected measurements?
 
Last edited:

JoinUs

New Member
Joined
Jan 6, 2023
Messages
73
I don't see any difference in the behaviour of Time Align in the current build compared to 5.20.13. Perhaps there is more variance in the delay estimation when measurements are made, I will investigate that.
Thanks for investigate.
 
Last edited:

JoinUs

New Member
Joined
Jan 6, 2023
Messages
73
Deleted. Confused sample rate with frequency range.
Now I saw your writing. What's mean "Possible display issue: Frequency display mismatch. Left shows 176.4kHz, right shows 88,199Hz." ?
Is it a problem with my monitor? Should I change the monitor?

And I measured it by applying the FIR filter with 1024tap only to the speaker with PEQ. (5.333ms) Can this cause such an error?
(But I don't think this is the problem because I've used the same FIR filter before and I've never experienced this kind of problem...)
(And other acquaintances who don't use the FIR filter sometimes say that if you use the Time align, it would merge strangely like the case I uploaded. He says he's measuring at nine close quarters)
 

G29

Member
Joined
Jun 20, 2019
Messages
93
Now I saw your writing. What's mean "Possible display issue: Frequency display mismatch. Left shows 176.4kHz, right shows 88,199Hz." ?
Is it a problem with my monitor? Should I change the monitor?

And I measured it by applying the FIR filter with 1024tap only to the speaker with PEQ. (5.333ms) Can this cause such an error?
(But I don't think this is the problem because I've used the same FIR filter before and I've never experienced this kind of problem...)
(And other acquaintances who don't use the FIR filter sometimes say that if you use the Time align, it would merge strangely like the case I uploaded. He says he's measuring at nine close quarters)
Sorry JoinUs, my post was not related to yours. Pilot error on my part.
 

John Mulcahy

REW Author
Thread Starter
Joined
Apr 3, 2017
Messages
7,536
Builds updated today with these changes:
  • Added: Trace options include a thick stroke choice
  • Changed: Export impulse as WAV allows sample counts up to 4M
  • Changed: Tweaks to delay estimation
  • Fixed: RTA on/off button was larger than it should be on Retina displays
  • Fixed: Graph zoom buttons were too far apart on Retina displays
  • Fixed: Graph frequency axis preset buttons were too wide on Retina displays
  • Fixed: Level meter text was blurred on Retina displays

Can you tell that I finally got a Retina display to plug into my mac mini? :)
 

JoinUs

New Member
Joined
Jan 6, 2023
Messages
73
Builds updated today with these changes:
  • Added: Trace options include a thick stroke choice
  • Changed: Export impulse as WAV allows sample counts up to 4M
  • Changed: Tweaks to delay estimation
  • Fixed: RTA on/off button was larger than it should be on Retina displays
  • Fixed: Graph zoom buttons were too far apart on Retina displays
  • Fixed: Graph frequency axis preset buttons were too wide on Retina displays
  • Fixed: Level meter text was blurred on Retina displays

Can you tell that I finally got a Retina display to plug into my mac mini? :)
Can "Tweaks to delay estimation" be applied only to new measurements? Or will the delay impulse alignment be improved with existing measurements?
'm sorry if I misunderstood!
 

John Mulcahy

REW Author
Thread Starter
Joined
Apr 3, 2017
Messages
7,536
The changes will only affect new measurements and are typically less than a couple of microseconds.
 

JoinUs

New Member
Joined
Jan 6, 2023
Messages
73
The changes will only affect new measurements and are typically less than a couple of microseconds.
Okay! So it's not related to the high-frequency anomaly that I reported a few days ago when I used Vetor Avg after doing Time Align.... =(
 

John Mulcahy

REW Author
Thread Starter
Joined
Apr 3, 2017
Messages
7,536
The dips you saw were due to the differing delays of the measurements, a new set of measurements might be more consistent in their delay figures.
 

G29

Member
Joined
Jun 20, 2019
Messages
93

@John Mulcahy ,

Thanks much !!!

V5.20.14 early access build


Builds updated today with these changes:
  • Added: Trace options include a thick stroke choice
  • Changed: Export impulse as WAV allows sample counts up to 4M
  • Changed: Tweaks to delay estimation
  • Fixed: RTA on/off button was larger than it should be on Retina displays
  • Fixed: Graph zoom buttons were too far apart on Retina displays
  • Fixed: Graph frequency axis preset buttons were too wide on Retina displays
  • Fixed: Level meter text was blurred on Retina displays
 

JoinUs

New Member
Joined
Jan 6, 2023
Messages
73
1683808911468.png


Is it possible to add the ability to simultaneously check left and right impulses while playing certain sounds in real time?
Among the programs I know, this is possible with the captured accurate program and smart.
It's a very useful feature for people who like to fine-align the microphone to the center of the left and right before measuring.
 

Marc Lombardi

Member
Joined
Apr 14, 2018
Messages
68
More  
Preamp, Processor or Receiver
Emotiva XMC-1
Main Amp
Nord One 2x700w
Additional Amp
Outlaw 7500 5x300w
Other Amp
Emotiva PA-1 300w
Universal / Blu-ray / CD Player
OPPO-205
Front Speakers
Magneplanar 3.7
Center Channel Speaker
Magneplanar CC5
Surround Speakers
Magneplanar MC1
Surround Back Speakers
Polk Dipole
Subwoofers
Outlaw Ultra X-12 and LFM1-C; Magneplanar DWM
Other Speakers or Equipment
MiniDSP 2x4
I installed the latest build this week. I've been using V5.20.14 for a month or so (ea 45, 47).

With ea58 that I installed May 9, the sweeps are playing about -10db quieter than they were before, all settings being unchanged. And without checking the LFE -10db option, it now measures same level as the other channels rather than +10db as it always had.
 

John Mulcahy

REW Author
Thread Starter
Joined
Apr 3, 2017
Messages
7,536
Levels are the same as previous builds and the same as 5.20.13 for the interfaces I have tested.
 

Marc Lombardi

Member
Joined
Apr 14, 2018
Messages
68
More  
Preamp, Processor or Receiver
Emotiva XMC-1
Main Amp
Nord One 2x700w
Additional Amp
Outlaw 7500 5x300w
Other Amp
Emotiva PA-1 300w
Universal / Blu-ray / CD Player
OPPO-205
Front Speakers
Magneplanar 3.7
Center Channel Speaker
Magneplanar CC5
Surround Speakers
Magneplanar MC1
Surround Back Speakers
Polk Dipole
Subwoofers
Outlaw Ultra X-12 and LFM1-C; Magneplanar DWM
Other Speakers or Equipment
MiniDSP 2x4
Levels are the same as previous builds and the same as 5.20.13 for the interfaces I have tested.
Wow, okay ... well I'll reinstall the previous build and test again. I can't imagine what would have caused this on my side. Thanks!
 

Marc Lombardi

Member
Joined
Apr 14, 2018
Messages
68
More  
Preamp, Processor or Receiver
Emotiva XMC-1
Main Amp
Nord One 2x700w
Additional Amp
Outlaw 7500 5x300w
Other Amp
Emotiva PA-1 300w
Universal / Blu-ray / CD Player
OPPO-205
Front Speakers
Magneplanar 3.7
Center Channel Speaker
Magneplanar CC5
Surround Speakers
Magneplanar MC1
Surround Back Speakers
Polk Dipole
Subwoofers
Outlaw Ultra X-12 and LFM1-C; Magneplanar DWM
Other Speakers or Equipment
MiniDSP 2x4
Levels are the same as previous builds and the same as 5.20.13 for the interfaces I have tested.
Okay, I tried two things. Since I last ran REW measurements I had done a Dirac Live calibration and loaded filters into my processor. I was measuring the result with ea58. So I went back to a Dirac calibration from early April and found the measurements with ea58 to be the same as I experienced yesterday ... overall levels down about -10db and the LFE always measuring same as other channels rather than the normal +10db.

Then I uninstalled ea58 and installed ea47 which is the last one I was using. The regular channel level was still a bit low, but not quite -10db. But the LFE measured normally at +10db above the other channels.

So there may be something in my system causing the overall levels to be lower, but it's worse in ea58 than ea47. The issue of LFE playing -10db is only there in ea58 ... and BTW it measures -10db irrespective of setting the LFE -10db option.

I'll keep investigating.
 
Status
Not open for further replies.
Top Bottom