Mac audio channels mixed up when playing videos with multi channel sound

Tony V.

Moderator
Staff member
Thread Starter
Joined
Apr 14, 2017
Messages
1,052
Location
Edmonton, AB, Canada
My AV System  
Preamp, Processor or Receiver
Onkyo TX RZ920
Main Amp
Samson Servo 600
Additional Amp
QSC MX1500
Universal / Blu-ray / CD Player
Panasonic 220
Front Speakers
EV Sentry 500
Center Channel Speaker
EV Sentry 500
Surround Speakers
Mission 762
Surround Back Speakers
Mission 762
Subwoofers
SVS PB13u
Video Display Device
Panasonic AE 8000
Remote Control
Logitech 1100
Other Equipment
Denon DT 625 CD/Tape unit, Nintendo WiiU, and more
ive got a strange problem, on my new to me iMac I'm using the media player ELmedia and the channels seem to be mixed up. The centre channel plays out of the soround left channel and the other channels don't seem right either. I know the files are good as they play fine on my USB stick that's plugged into my BluRay player.
ELmedia player seems to be regarded as a well liked player so I am confused.
I'm connected to my receiver from the iMac's Thunderbolt out to HDMI in on the receiver.
 

Tony V.

Moderator
Staff member
Thread Starter
Joined
Apr 14, 2017
Messages
1,052
Location
Edmonton, AB, Canada
My AV System  
Preamp, Processor or Receiver
Onkyo TX RZ920
Main Amp
Samson Servo 600
Additional Amp
QSC MX1500
Universal / Blu-ray / CD Player
Panasonic 220
Front Speakers
EV Sentry 500
Center Channel Speaker
EV Sentry 500
Surround Speakers
Mission 762
Surround Back Speakers
Mission 762
Subwoofers
SVS PB13u
Video Display Device
Panasonic AE 8000
Remote Control
Logitech 1100
Other Equipment
Denon DT 625 CD/Tape unit, Nintendo WiiU, and more
Well, it seems this is a Mac issue in general. Doing a search found this solution,

  1. 1. You need to enable AC3/DTS passthrough. Go to Applications>Utilities>Terminal. When the application opens, copy and paste the following, without the quotes, then press enter: “defaults write com.cod3r.a52codec attemptPassthrough 1” and “defaults write org.perian.Perian attemptDTSPassthrough 1”.
  2. 2. Connect the HDMI cable from your AVR to your Mac. Make sure you select the proper mode on your AVR so your computer is recognized. Make sure your audio output device in OS X is changed to, "receiver" from the default "Internal Speakers", otherwise, your audio will play through your internal computer speakers. You can quickly switch the audio output device by clicking on the sound icon in the top menu bar, whilst holding option on the keyboard. If you don't see the sound/volume icon in your menu bar, go to the apple icon in the top left, click System Preferences>Sound. Then click the box for "Show volume in menu bar". This will make your life easier.
  3. 3. Go to Applications>Utilities>Audio MIDI Setup
  4. 4. On the left side of the "Audio Devices" window that appears, click "HDMI".
  5. 5. Change Format to 48000.0 Hz and in the dropdown to the right, select “8ch-24bit Integer”.
  6. 6. Now click “Configure Speakers”. In the top right, select the surround system you have. I have 5 speakers (no subwoofer), but I selected “5.1 Surround”. Click each speaker name to make sure sound comes out of the speaker name you just clicked. Adjust as necessary.

That seemed to fix the issues, my question is does this effect the quality of the audio coming out of the Mac?
 

dc2bluelight

Member
Joined
Mar 17, 2018
Messages
63
I occasionally use VLC to play audio/video, just setting for HDMI and "pass through" within VLC does the trick. Once you're set for "pass through" no further settings should be required. The only time you need to "Configure Speakers" is if your software decodes the bitstream first, or the audio doesn't exist as a multichannel bitstream, like it's coming out of a DAW.
 
Top Bottom