Umik is detected, but not used on Mac 10.14.1

Discussion in 'Official REW (Room EQ Wizard) Support Forum' started by Karsten Faesser, Dec 4, 2018.

  1. Karsten Faesser

    Karsten Faesser New Member
    Thread Starter

    Joined:
    Nov 28, 2018
    Messages:
    4
    Likes Received:
    0
    I tested a bit with the new 5.20 Beta 1 on my Mac. While getting plausible measuring under Parallels WIN 10 on the same hardware I now can state that whatever I select always the internal Mic of the Mac is used. Can anyone help me out with a hint what goes wrong?

    many thanks
    Karsten
     
  2. John Mulcahy

    John Mulcahy REW Author

    Joined:
    Apr 3, 2017
    Messages:
    990
    Likes Received:
    160
    Can you show a screenshot of your REW soundcard preferences?
     
  3. Karsten Faesser

    Karsten Faesser New Member
    Thread Starter

    Joined:
    Nov 28, 2018
    Messages:
    4
    Likes Received:
    0
    Hi John,

    thank you for your immediate reply. Sure I can provide my details. Thought I best provide the whole "starting" procedure as a multi page PDF. Please let me know if this adequate and delivers the information you requested.

    One interesting detail I may add:
    when starting a measurement each time I am asked to allow usage of the umik and have to press "OK".
    Might be something to look after…
     

    Attached Files:

  4. John Mulcahy

    John Mulcahy REW Author

    Joined:
    Apr 3, 2017
    Messages:
    990
    Likes Received:
    160
    Thanks. Strange that the channel selections are not enabled for the mic, can't think what could cause that. Can you post a screenshot of the Audio Midi setup for the UMIK? (Applications -> Utilities). You implied the mic was working under Parallels, so you are probably aware of this, but make sure the USB connector is firmly pressed into the back of the mic.

    The mic access prompt appears each time you try and access an input after starting REW, though I don't see it again until the next time I start REW. I've reported that to Oracle, seems to be a Java vs 10.14 issue.
     
  5. Karsten Faesser

    Karsten Faesser New Member
    Thread Starter

    Joined:
    Nov 28, 2018
    Messages:
    4
    Likes Received:
    0
    Hi John,
    I have attached the Audio Midi Setup Screenshot as well as another one from REW comparing two curves (blue = internal MIC, orange = UMIK). While playing around I stumbled across "deleting prefs" in REW and tried so. After that I was able to make the orange measurement, which looks plausible to me. Interestingly this state doesn't last long. As soon as I switch over to the internal mic and than back to the UMIK, again only the internal MIC is used. Until I delete prefs again and start from scratch.

    Hope that helps searching for what goes wrong…

    Thanks for taking care and the precious work you have done so far.
    Karsten
     

    Attached Files:

  6. John Mulcahy

    John Mulcahy REW Author

    Joined:
    Apr 3, 2017
    Messages:
    990
    Likes Received:
    160
    One additional request : on the soundcard preferences there is a button to generate a debug file, could you attach that also?
     
  7. Karsten Faesser

    Karsten Faesser New Member
    Thread Starter

    Joined:
    Nov 28, 2018
    Messages:
    4
    Likes Received:
    0
    I am out on the road travelling.
    This one is without the UMIK attached (left at home). Will do one with the UMIK on Saturday.

    Regards
     

    Attached Files:

  8. John Mulcahy

    John Mulcahy REW Author

    Joined:
    Apr 3, 2017
    Messages:
    990
    Likes Received:
    160
    I understand why the channel selections were not enabled now, since the internal mic is mono. I'm not clear why the internal mic is being selected rather than the UMIK but I've made some changes to the device handling for the next beta that might help.
     

Share This Page