UMIK-2 drama after latest Windows Update

AJ Soundfield

Active Member
Thread Starter
Joined
May 21, 2017
Messages
377
Location
Tampa
My AV System  
Preamp, Processor or Receiver
Yamaha RXA800, Denon AVR-X4500, Lexicon MC10
Main Amp
Hypex Ncores
Additional Amp
Abacus Ampino, Triode Corp TRV-35SE
Computer Audio
AudioEngine D2
DAC
NAD M51
Universal / Blu-ray / CD Player
Yamaha BDA1010
Front Speakers
Soundfields
Center Channel Speaker
Soundfields, KEF Q150
Surround Speakers
Soundfields
Surround Back Speakers
Revel M16
Subwoofers
Soundfield Cardioid Rythmik Servo
Other Speakers or Equipment
AVA ABX
Anyone else having issues with their Umik-2 after the latest Windows update? Everything worked fine before. 3 laptops, two with Windows 11, one with 10, all latest updates (KB5016691 & KB5016594) none recognize Umik-2 after update. Plugged in Umik-1, no problems. Reverted to previous versions of REW, tried Umik-2, no dice. Will post on Minidsp support forum later, but searched there, could not find anything.
TIA
 

pklose

Member
Joined
Jan 11, 2020
Messages
55
No, my Umik-2 works fine on Win 11, Win 10, macOS... Have you updated to the latest firmware?
 

AJ Soundfield

Active Member
Thread Starter
Joined
May 21, 2017
Messages
377
Location
Tampa
My AV System  
Preamp, Processor or Receiver
Yamaha RXA800, Denon AVR-X4500, Lexicon MC10
Main Amp
Hypex Ncores
Additional Amp
Abacus Ampino, Triode Corp TRV-35SE
Computer Audio
AudioEngine D2
DAC
NAD M51
Universal / Blu-ray / CD Player
Yamaha BDA1010
Front Speakers
Soundfields
Center Channel Speaker
Soundfields, KEF Q150
Surround Speakers
Soundfields
Surround Back Speakers
Revel M16
Subwoofers
Soundfield Cardioid Rythmik Servo
Other Speakers or Equipment
AVA ABX
No, my Umik-2 works fine on Win 11, Win 10, macOS... Have you updated to the latest firmware?
Not yet, but will do. Ironically went to a friends place Sun who just got a UMik-2 . Same exact issue with a no recent updates W10 laptop. His old Umik-1 worked fine. Guessing there are others out there.
 

AJ Soundfield

Active Member
Thread Starter
Joined
May 21, 2017
Messages
377
Location
Tampa
My AV System  
Preamp, Processor or Receiver
Yamaha RXA800, Denon AVR-X4500, Lexicon MC10
Main Amp
Hypex Ncores
Additional Amp
Abacus Ampino, Triode Corp TRV-35SE
Computer Audio
AudioEngine D2
DAC
NAD M51
Universal / Blu-ray / CD Player
Yamaha BDA1010
Front Speakers
Soundfields
Center Channel Speaker
Soundfields, KEF Q150
Surround Speakers
Soundfields
Surround Back Speakers
Revel M16
Subwoofers
Soundfield Cardioid Rythmik Servo
Other Speakers or Equipment
AVA ABX
Turned out to be multiple reasons. My old W10 laptop, Drivers/Firmware updates did it, Umik-2 now recognized again (after yet another Win Update this week).
My W11 Laptop, 2 usb cables that worked on W10 laptop swapped for 3rd cable, bingo, Umik2 recognized. No driver/firmware update needed. That one's a bit weird but hey...
Will update friends W10 laptop next time over. Nothing to do with REW.
 

ddude003

Senior Member
Joined
Aug 13, 2017
Messages
925
Location
Somewhere Northeast of Kansas City Missouri
My AV System  
Preamp, Processor or Receiver
PrimaLuna Dialogue Premium TubePre (2 channel+sub)
Main Amp
McIntosh MC152 SS Amp (2 channel)
Additional Amp
Yamaha RX-A850 Pro (the other 5 channels lol)
Computer Audio
MacBook Pro, Custom i7 7700k De-lid 2xAsus1080ti GFX build, Audirvana+, LiquidSonics, SoX
DAC
Chord Electronics Ltd. Qutest
Universal / Blu-ray / CD Player
Sony UBP-X700 /M Ultra HD 4K HDR
Front Speakers
Martin Logan ElectroMotion ESL
Center Channel Speaker
Martin Logan Motion C2
Surround Speakers
Martin Logan Motion 4
Surround Back Speakers
Martin Logan Motion 4 (yes, another set of these)
Subwoofers
Martin Logan Dynamo 700
Other Speakers or Equipment
Cifte 12AU7 NOS & Genalex Gold Lion Tubes in Pre
Video Display Device
Samsung The Premiere LSP7T UST Laser Projector
Screen
Elite Screens Aeon CLR3 0.8 Gain 103-inch
Remote Control
PrimaLuna & Lumin iApp
Streaming Equipment
Netgear Nighthawk S8000 Streaming Switch, Lumin U1 Mini Streamer/Transport
Streaming Subscriptions
Roon & QoBuz Studio Premier, Amazon Prime & Netflix
Other Equipment
ThrowRug, SaddleBlankets, WideBand & BaseTraps...
Something to do with a USB 2.0 vs USB 3.0 or power from the host computer usb side???
 

Lee Bairnsfather

New Member
Joined
Aug 18, 2017
Messages
5
After today's upgrade to V5.20.12, my UMIK-1 is no longer an option in Preferences. Yesterday, it worked fine. I'm running Windows 10 Pro, 21H1, OS Build 19043.2006. I'm using a USB 3.0 port.
 

John Mulcahy

REW Author
Joined
Apr 3, 2017
Messages
5,845
Are you using Java drivers or ASIO? Both the older and newer (USB-C) UMIK-1 work for me with 5.20.12.
 

Lee Bairnsfather

New Member
Joined
Aug 18, 2017
Messages
5
Uninstalling V5.20.12 and reinstalling V5.20.3 resolved the problem. I believe I am using JAVA drivers.

It's worth noting that with V5.20.12 installed, I could no longer see the UMIK in Windows Sound settings. After reverting to V5.20.3, I can once again see the UMIK in Sound settings.
 

John Mulcahy

REW Author
Joined
Apr 3, 2017
Messages
5,845
Uninstalling V5.20.12 and reinstalling V5.20.3 resolved the problem. I believe I am using JAVA drivers.

It's worth noting that with V5.20.12 installed, I could no longer see the UMIK in Windows Sound settings. After reverting to V5.20.3, I can once again see the UMIK in Sound settings.
Difficult to understand, since REW has no way of affecting what devices Windows does or doesn't see. Are you running the 64-bit or 32-bit build of REW?
 

AJ Soundfield

Active Member
Thread Starter
Joined
May 21, 2017
Messages
377
Location
Tampa
My AV System  
Preamp, Processor or Receiver
Yamaha RXA800, Denon AVR-X4500, Lexicon MC10
Main Amp
Hypex Ncores
Additional Amp
Abacus Ampino, Triode Corp TRV-35SE
Computer Audio
AudioEngine D2
DAC
NAD M51
Universal / Blu-ray / CD Player
Yamaha BDA1010
Front Speakers
Soundfields
Center Channel Speaker
Soundfields, KEF Q150
Surround Speakers
Soundfields
Surround Back Speakers
Revel M16
Subwoofers
Soundfield Cardioid Rythmik Servo
Other Speakers or Equipment
AVA ABX
Same thing happened to me when I updated REW yesterday after getting everything working earlier! W11 laptop, 64 bit with Java. Reverted to older version of REW and it worked again. I then installed the latest Umik Firmware 2.6 iirc.
Can try updating REW again, but hurricane headed this way, so....
 

John Mulcahy

REW Author
Joined
Apr 3, 2017
Messages
5,845
REW, like other Java programs, can't access hardware or any low level features of the OS directly, the Java runtime takes care of all the low level interfacing. I'll check with Pavel to see if he can think of any way the WASAPI exclusive code could have an influence.
 

thothsong

Member
Joined
Jun 29, 2021
Messages
173
FWIW, both UMIK-1 and UMIK-2 work for me with V5.20.13 on Win10, both Java and ASIO4ALL.
 

phofman

Registered
Joined
Jun 26, 2019
Messages
29
Please what is the actual issue?

With REW only installed or actually running?

How does the device disappear from the windows control panel? Like it's there, you start REW, and it's gone? You quit REW and it re-appears? Or something else going on?

Do you have other audio access like ASIO4All running at the same time? Is it configured for the same device?

Troubleshooting will need more detailed and precise info to start with. Thanks a lot.
 

ddude003

Senior Member
Joined
Aug 13, 2017
Messages
925
Location
Somewhere Northeast of Kansas City Missouri
My AV System  
Preamp, Processor or Receiver
PrimaLuna Dialogue Premium TubePre (2 channel+sub)
Main Amp
McIntosh MC152 SS Amp (2 channel)
Additional Amp
Yamaha RX-A850 Pro (the other 5 channels lol)
Computer Audio
MacBook Pro, Custom i7 7700k De-lid 2xAsus1080ti GFX build, Audirvana+, LiquidSonics, SoX
DAC
Chord Electronics Ltd. Qutest
Universal / Blu-ray / CD Player
Sony UBP-X700 /M Ultra HD 4K HDR
Front Speakers
Martin Logan ElectroMotion ESL
Center Channel Speaker
Martin Logan Motion C2
Surround Speakers
Martin Logan Motion 4
Surround Back Speakers
Martin Logan Motion 4 (yes, another set of these)
Subwoofers
Martin Logan Dynamo 700
Other Speakers or Equipment
Cifte 12AU7 NOS & Genalex Gold Lion Tubes in Pre
Video Display Device
Samsung The Premiere LSP7T UST Laser Projector
Screen
Elite Screens Aeon CLR3 0.8 Gain 103-inch
Remote Control
PrimaLuna & Lumin iApp
Streaming Equipment
Netgear Nighthawk S8000 Streaming Switch, Lumin U1 Mini Streamer/Transport
Streaming Subscriptions
Roon & QoBuz Studio Premier, Amazon Prime & Netflix
Other Equipment
ThrowRug, SaddleBlankets, WideBand & BaseTraps...
Could this be a USB Selective Suspend setting??? These are USB powered Mics... And if you are using a windoz laptop... BTY I don't have any issues running windows 10 pro on my desk side with REW V5.20.11, V5.20.12 or V5.20.13... And as a reminder, a single usb cable 10 ft or less is best...
 
Last edited:

Lee Bairnsfather

New Member
Joined
Aug 18, 2017
Messages
5
I just installed V5.20.13 and everything works fine. Preferences now lists 2 separate instances of UMIK-1:

Microphone (Umik-1 Gain: 12db)
EXCL: Microphone (Umik-1 Gain: 12db)

The EXCL instance seems to have +20db gain over the standard Microphone instance. Otherwise, everything seems back to normal with V5.20.13.
 

John Mulcahy

REW Author
Joined
Apr 3, 2017
Messages
5,845
EXCL indicates WASAPI exclusive access to devices, bypassing Windows system volume controls but volume controls within the device itself may still be active (and may be controlled by the Windows sliders). Newer UMIK-1 (USB-C connectors) do not have a volume control within the device, older UMIK-1 did.

The only difference between .12 and .13 is a fix for an issue saving new measurements together with measurements loaded from file, so the mic issues are probably unrelated to REW or REW versions.
 
Top Bottom