REW Beta Release Problems calibration file

Antonio Di Motta

Active Member
Thread Starter
Joined
Feb 8, 2018
Messages
103
Location
Italy
Good evening,
I noticed that the generated calibration file is associated with the selection of the sound card through the device name. I use a raspberry and the name of the device selected normally is default device but since it does not correspond to any audio devive no calibration file is associated. Would it be possible to have a calibration file automatically associated for the default device?
Thank you
 

John Mulcahy

REW Author
Joined
Apr 3, 2017
Messages
2,131
That wouldn't be a good idea. The default device can change without REW being able to tell, so it could end up using an incorrect cal file. That is why the cal file is linked to the device name. Why not just select the audio device name?
 

Antonio Di Motta

Active Member
Thread Starter
Joined
Feb 8, 2018
Messages
103
Location
Italy
Because on rasbian even selecting the device name on input and output then Defaul device appears in the menu and for each measurement it is necessary to set the sound card calibration file. This is very impractical ....
 

John Mulcahy

REW Author
Joined
Apr 3, 2017
Messages
2,131
That must be a Raspbian 'feature' then, haven't seen behaviour like that on Windows or macOS. If the card is removed while REW is running and so disappears from the list of available devices, or if the card refuses to provide audio lines, the selection would revert to Default device but beyond that REW selects and uses the named devices that had previously been selected.
 

Antonio Di Motta

Active Member
Thread Starter
Joined
Feb 8, 2018
Messages
103
Location
Italy
Are you sure it also works correctly on PCs with Linux installed? In my opinion the defaut device is a feature that is of all linux systems and since REW very well pretends on this operating system it would be necessary to find a solution to this problem.
Thanks anyway ...
 

John Mulcahy

REW Author
Joined
Apr 3, 2017
Messages
2,131
Default device is offered as an option to select when using Java drivers on any supported OS. The soundcard cal files are linked to specific devices, not Default, so a device selection needs to be made to use them.
 

Antonio Di Motta

Active Member
Thread Starter
Joined
Feb 8, 2018
Messages
103
Location
Italy
In fact the selection of the device works on linux, I tried on a PC with an external SB HD Usb sound card and selecting the HD output device and input (plughd 2.0) remains correctly set. At this point I think it's a problem that only occurs on the Raspberry with Raspbian OS. To overcome this problem, perhaps, it would be useful to implement a flag on the preference sound card panel to disable the management of calibration files linked with the device name. It would be very useful for me and I would avoid having to set the file on every measure.
Many thanks
 

John Mulcahy

REW Author
Joined
Apr 3, 2017
Messages
2,131
Is your soundcard cal not pretty flat, Antonio? For acoustic measurements soundcard responses are usually flat enough they are not needed. They are more relevant when measuring electronic equipment responses.
 

Antonio Di Motta

Active Member
Thread Starter
Joined
Feb 8, 2018
Messages
103
Location
Italy
My measurement system is used both for measurements of electro-acoustic response to impedance curve diffusers as well as response curves of amplifiers. It needs to have a perfect compensation of the response and of the phase of the measurement system. I use as a CPU a raspberry PI3 + as a BF amplifier an integrated LM3886 of about 20W an audio card currently based on the PCM2902 and a switching system controlled by the CPU to measure the microphone response or external input and make Impedance measurements. Lately I am modifying the instrument to use a more performing sound card not connected via USB but through the I2C serial bus in order to use sampling frequencies up to 192Khz. Calibration is very important for a measurement system, I would be grateful if you could solve this problem.

Thank you
 

John Mulcahy

REW Author
Joined
Apr 3, 2017
Messages
2,131
Please use the "Generate debug file" button on the soundcard preferences and attach the file it generates here.
 

Antonio Di Motta

Active Member
Thread Starter
Joined
Feb 8, 2018
Messages
103
Location
Italy
Good evening Mr. John, I wanted to thank you for solving the problem. I send you the debug file as requested
together with the screens made before starting the calibration and the second one to verify the correct association
of the audio device with the calibration file and finally after performing the REW restart.

Hardware Raspberry Pi3 + Sound card HIFIBerry DAC + ADC
S.O. Raspbian kernel 4.19.66-v7 + # 1253 SMP
Java (TM) SE Runtime Environment (build 1.8.0_65-b17)
Java HotSpot (TM) Client VM (build 25.65-b01, mixed mode)

Thank you
 

Attachments

Antonio Di Motta

Active Member
Thread Starter
Joined
Feb 8, 2018
Messages
103
Location
Italy
After performing the REW restart the device shown in the preference setup returns to being
Default device does not remain as set sndrpihifiberry (plughw0,0) and does not associate
the correct calibration file.

Thank you
 

John Mulcahy

REW Author
Joined
Apr 3, 2017
Messages
2,131
That looks like a fairly old JRE8 release, at least by Oracle release numbering. Maybe an OpenJDK version number?

The soundcard_debug looks very odd, the audio interface is not reporting any audio lines for input or output and no supported audio formats. Haven't seen anything like that from a Linux system before.

I'll make a test build for you to try that supports the default device, but there is something odd about that setup. There have been posts from a few others using various versions of the Pi, seemingly without such issues.
 

John Mulcahy

REW Author
Joined
Apr 3, 2017
Messages
2,131
Yes, looks the same. I sent you a link to a test build earlier today, via the 'Conversations' system - the Envelope icon by your username in the forum top banner.
 

Antonio Di Motta

Active Member
Thread Starter
Joined
Feb 8, 2018
Messages
103
Location
Italy
John, I wanted to tell you that REW with the default audio device does not allow SPL level calibration.
After fixing the lack of association of the calibration file, could you also correct the SPL calibration?
I know that you don't recommend using Default as an input and output device, but on the Raspberry,
inexplicably, set it this way, while with a Linux PC it works regularly.

Thanks
 

Attachments

Antonio Di Motta

Active Member
Thread Starter
Joined
Feb 8, 2018
Messages
103
Location
Italy
I forgot to tell you that I tried with the version of REW 5.20 beta 25 but I think that even with the previous one it didn't work, only that I had not tried to carry out the level calibration.
Thanks
 

John Mulcahy

REW Author
Joined
Apr 3, 2017
Messages
2,131
OK, I've done that for the next build. It was intentional, like the lack of soundcard cal support for the default output, but I have removed the restriction to get around the problems with the Pi.
 

Antonio Di Motta

Active Member
Thread Starter
Joined
Feb 8, 2018
Messages
103
Location
Italy
Thanks John, I wanted to ask you if it is possible to do so in a differentiated way to choose the color of the phase and of the amplitude / impedance, because sometimes on the graph they become confused, or to trace the phase always of the same color, for example black in order to make it immediately identifiable.

thanks a lot
 

John Mulcahy

REW Author
Joined
Apr 3, 2017
Messages
2,131
Black is already used for the mic cal trace, and various shades of grey are used for the traces related to minimum phase or the impedance model traces. That leaves options of a colour derived from, but different to, the measured trace colour (such as a rotated hue) and/or using a different stroke type for phase, such as dotted. Changing the stroke type while keeping the same colour doesn't seem to help much visually in distinguishing the magnitude and phase, I'll change both colour and stroke for the next build and see what reactions that gets.
 
Top Bottom