REW Beta Release Loss of connection with the Octa sound card

Virgilio

Registered
Thread Starter
Joined
Apr 4, 2021
Messages
16
42444
42445
Good morning to all gentlemen. I'm having a problem with the latest beta version of REW. In practice, after some time, the software loses the connection with the sound card without any warning. This dialog box appears. Do you by any chance know what this anomaly is due to?i am using this computer:ACEPC AK1 Mini PC,Windows 10(64 bit) Computer desktop Intel Celeron Apollo Lake J3455 (fino a 2,3GHz) Computer desktop[4GB/64GB/Supporto SSD da 2,5"/ SSD mSATA/Doppio WiFi/Gigabit Ethernet/BT 4.2/4K]
 

John Mulcahy

REW Author
Joined
Apr 3, 2017
Messages
4,460
If the interface is connected by USB the PC may be powering down the USB controller when it thinks it isn't being used. This post from Sam Adams has details on how to prevent that.
 

Virgilio

Registered
Thread Starter
Joined
Apr 4, 2021
Messages
16
I have done all the procedures listed and I have disabled all the power saving options on the external sound card. the problem persists. How should I do?
 

John Mulcahy

REW Author
Joined
Apr 3, 2017
Messages
4,460
Please note that the message "Can not found a device. Please connect the device." comes from the Octa-Capture driver, not from REW.
 

Virgilio

Registered
Thread Starter
Joined
Apr 4, 2021
Messages
16
at first everything works correctly. The problem is that after five / six minutes of not using the software, it displays this alarm. I do not know what to do. What do you recommend? PS: I also tried uninstalling and reinstalling the sound card drivers but nothing has changed. I also point out that I used to work with Smaart V8 before and have never had this type of problem. Now that I would like to switch to the intensive and real use of REW, I am experiencing this problem. Compared to before the wiring has not been changed, everything is the same.
 

Virgilio

Registered
Thread Starter
Joined
Apr 4, 2021
Messages
16
it is Roland Octa Capture ua-1010.
PS: could it be a solution to install the asio4all drivers?
 

EarlK

Member
Joined
May 22, 2017
Messages
208
I'd advise treating your symptoms as an indication of your computer starving for RAM.

IOW, close down all your extra networking apps. ( such as AuroraNet ) that might be monopolizing RAM usage.

If that doesn't help then Un-Install REW and then reinstall, while choosing the smallest RAM footprint ( choice ) within the REW install sequence of windows

Alternately, one can have both the 32bit + 64bit versions co-existing on the same 64bit machine.
- Using the 32bit version of REW "might" offer a lower RAM footprint.

:)
 
Last edited:

Virgilio

Registered
Thread Starter
Joined
Apr 4, 2021
Messages
16
I am attaching a video to show you how the sound card freezes and does not reactivate until a restart
 

Virgilio

Registered
Thread Starter
Joined
Apr 4, 2021
Messages
16
Good morning. Sorry if I still bother you but, unfortunately, I can't solve this problem. I have tried everything: I have changed usb ports, I have removed all energy savings, I have put Windows at maximum performance, I have removed all the automatic disconnections of the usb ports, I have also increased the buffer. unfortunately the problem persists. I also did the same tests with the smaart v8 software and it didn't give me any problems after several minutes of inactivity. so I repeat the problem present on the latest beta of Rew. the software, after a few minutes of inactivity, loses the connection with the sound card and it is necessary to restart the operating system to regain the connection with the Octa capture sound card. Will you please help me? I like this software very much and would like to use it safely.
 

EarlK

Member
Joined
May 22, 2017
Messages
208
As mentioned earlier, I believe you are bogging down your machine ( computer ) with all your active networking and the first thing that Win10 does to free up needed CPU space is to boot ( turn off ) processes that have the lowest priority numbers ( these are set in Win10's Task Manager ).

I don't know if its REW ( Java ) that's being throttled back or your soundcard's software driver.

What you might want to try is increasing the operational priority ( within Win10's Task Manager ) of each ( both the soundcard driver and the REW application ).

Read; Setting Application Priority for a quick briefing on how to accomplish setting running Priorities.

My guess as to why you only have a problem with REW but not Smaart is one of different Priority Settings.

My best guess ( & that's about all I have to offer ) .

:)
 

sm52

Member
Joined
Mar 14, 2019
Messages
257
Virgilio
ask someone for another sound card with two inputs and two outputs. Connect. Wait 30 minutes or as long as necessary for your sound card to lose communication with REW. This will check if your card or REW is to blame.
 

John Mulcahy

REW Author
Joined
Apr 3, 2017
Messages
4,460
You could try FlexASIO as an alternative ASIO wrapper for the card's WDM drivers. It can be configured in REW (REW will create the required FlexASIO.toml file).
 

sam_adams

Member
Joined
May 23, 2017
Messages
101
One other way to test if it is a PC issue or a driver issue is to install the Octa driver, Java, and REW on your Acer laptop and see if the behavior replicates itself there. If it doesn't, then it's probably the AcePC AK1 you're running it on.
 

Virgilio

Registered
Thread Starter
Joined
Apr 4, 2021
Messages
16
Update. With the same settings on Rew and Windows 10 (energy saving, maximum performance and disabling the disconnection function of the USB ports) I tried with an Acer laptop and Motu M2 sound card, Rew works correctly and does not freeze with no use afterwards 7/8 minutes. What could I do, since I can't change the computer in the Rack ???
PS: Flexasio and asio4all they didn't recognize the Roland Octa Capture sound card and so I uninstalled them
 

John Mulcahy

REW Author
Joined
Apr 3, 2017
Messages
4,460
PS: Flexasio and asio4all they didn't recognize the Roland Octa Capture sound card and so I uninstalled them
They use the WDM drivers, so you may need to install WDM drivers for the Octa Capture for them to work. They allow access to devices that appear in the Windows Audio playback and recording device lists.
 

Virgilio

Registered
Thread Starter
Joined
Apr 4, 2021
Messages
16
Can you kindly tell me where I can download them? Thanks so much
 

Virgilio

Registered
Thread Starter
Joined
Apr 4, 2021
Messages
16
update.
I did a further test, that is, I installed and tried with another sound card, the MOTU M2 on the ACEPC AK1 Mini PC. It works correctly and never disconnects. I automatically find that the problem lies in the Roland Octa Capture 1010 sound card drivers.
 

Virgilio

Registered
Thread Starter
Joined
Apr 4, 2021
Messages
16
Update. Loss of connection to the sound card occurs only when Rew is minimized in the bar below (not in the foreground). If rew remains open in the foreground, there is no connection loss.
 
Top Bottom