Dutch & Dutch 8c EQ

echoechocho

Registered
Joined
Nov 12, 2018
Messages
4
Hello John,

I also have problems between REW and D&D 8c.
REW does not automatically find the required settings and player files.
Manual searching doesn't really help either.
At the end the following message always appears: "java.lang.NullPointerException".

In the attachment you see various screenshots and informations about my experiments, which were made with two different MacBooks. The internal Mac OS firewall was always turned off.

However, with the same negative result.

Maybe my information will help you to solve the problem.

Best regards,
Henner
 

Attachments

Burkut

Registered
Joined
Jul 29, 2020
Messages
5
My AV System  
Preamp, Processor or Receiver
Lindemann Music Book,Roon Nuc
Main Amp
Absolare
Additional Amp
Quad II 80
Other Amp
none
Universal / Blu-ray / CD Player
none
Front Speakers
Cube Audio Nenuphar,Dutch&Dutch 8C
Center Channel Speaker
none
Surround Speakers
none
Surround Back Speakers
none
Front Height Speakers
none
Rear Height Speakers
none
Subwoofers
none
Other Speakers or Equipment
none
Video Display Device
none
Screen
none
Remote Control
none
Other Equipment
none
Today I also tried fresh hosts file, it did not helped.
Running old windows pc on the same network works fine. I did some test and noticed that REW EQ filters only adjust " I followed the D&D tutorial" the peaks and doing nothing for the deeps. Is that normal ? If this is a room correction should add filters also to deeps.
Ps : Also changed few settings to adjust to deeps but did not work, FYI
 

John Mulcahy

REW Author
Joined
Apr 3, 2017
Messages
3,334
I also have problems between REW and D&D 8c.
REW does not automatically find the required settings and player files.
Thanks Henner. That is a different problem, the speakers are found but they do not have a local network address, just a mac address. I think that is something to report to D&D, I will let them know.
 

John Mulcahy

REW Author
Joined
Apr 3, 2017
Messages
3,334
Running old windows pc on the same network works fine. I did some test and noticed that REW EQ filters only adjust " I followed the D&D tutorial" the peaks and doing nothing for the deeps. Is that normal ? If this is a room correction should add filters also to deeps.
Ps : Also changed few settings to adjust to deeps but did not work, FYI
Filling dips is risky, as they can be very localised so fixing a dip at the measurement position can create a peak from the correction a short distance away. To allow REW to apply boost filters to try and address dips you need to set the "Individual max boost" and "Overall max boost" in REW's Filter Tasks pane with the gains REW is allowed to use. The 8c filters have a 6 dB gain limit so any dip more than that (or more than the values entered for the boost settings) will be ignored. You can also manually apply filters of your own.
 

echoechocho

Registered
Joined
Nov 12, 2018
Messages
4
Thanks Henner. That is a different problem, the speakers are found but they do not have a local network address, just a mac address. I think that is something to report to D&D, I will let them know.
Hello John,
thank you for your quick reply.
However, my D&D 8c have a fixed IP address in the network. Only currently no permission for an independent port release. Here again the screenshots. Many thanks and best regards, Henner.
 

Attachments

John Mulcahy

REW Author
Joined
Apr 3, 2017
Messages
3,334
Good to know, but the speakers are not returning any local network address in their m-DNS responses, just their MAC address:

REW V5.20 Beta 56 startup on Jul 29, 2020 6:01:54 PM
Scan for 8c on Jul 29, 2020 6:07:23 PM
Found 8c-1037 with these addresses:
Address: /fe80:0:0:0:679:b7ff:feac:d8c0
8c-1037 is running 1.4.57
Could not get a network address for 8c-1037 address list size: 1
Found 8c-1038 with these addresses:
Address: /fe80:0:0:0:679:b7ff:fea0:a050
8c-1038 is running 1.4.57
Could not get a network address for 8c-1038 address list size: 1
Speakers:
8c-1037
8c-1038

Groups:
A containing 8c-1037 8c-1038
 

echoechocho

Registered
Joined
Nov 12, 2018
Messages
4
Good to know, but the speakers are not returning any local network address in their m-DNS responses, just their MAC address:

REW V5.20 Beta 56 startup on Jul 29, 2020 6:01:54 PM
Scan for 8c on Jul 29, 2020 6:07:23 PM
Found 8c-1037 with these addresses:
Address: /fe80:0:0:0:679:b7ff:feac:d8c0
8c-1037 is running 1.4.57
Could not get a network address for 8c-1037 address list size: 1
Found 8c-1038 with these addresses:
Address: /fe80:0:0:0:679:b7ff:fea0:a050
8c-1038 is running 1.4.57
Could not get a network address for 8c-1038 address list size: 1
Speakers:
8c-1037
8c-1038

Groups:
A containing 8c-1037 8c-1038
Hello John, thank you for your support.
I have already informed Martijn Mensink from Dutch & Dutch of your information.
Best regards, Henner.
 

John Mulcahy

REW Author
Joined
Apr 3, 2017
Messages
3,334
Hello John, thank you for your support.
I have already informed Martijn Mensink from Dutch & Dutch of your information.
I have sent a link via the conversation system to a test version to try that uses the IPV6 address to connect, that might fix the problem you are seeing.
 

SatBox

New Member
Joined
Dec 29, 2018
Messages
10
An update... Twice, and it is very very rare, I also had the display of a pop-up asking to allow incoming network connections for REW (see the screenshot).

Of course, each time, I have selected "Allow". In one case, I could see the 8c's in REW but, in the other case, even after allowing incoming connections, no 8c's in REW!

For some reason, I really feel that REW has some troubles to find the 8c's and, when it succeeds, the system asks to allow incoming connections but it seems that the connection to the 8c's is very fragile.

Also, what is a bit strange is that in my firewall config incoming connections to REW are allowed!

Once again, I can ping the speakers and the discovery via lanspeaker.com works very well.

Best regards.


33855
33856
 

SatBox

New Member
Joined
Dec 29, 2018
Messages
10
Another update: I also tried from a fresh Mac OS Catalina 10.15.6 installation and the problem is the same.
 

John Mulcahy

REW Author
Joined
Apr 3, 2017
Messages
3,334
I am away this week, I will look into this further when I get back. Strange though, no idea why it is fine on my mac mini but doesn't see anything on your Mac.
 

SatBox

New Member
Joined
Dec 29, 2018
Messages
10
Yes, strange. Please do not forgett that[U] Burkut[/U] has the same issue with his MAC and that when I run REW in a Windows 10 virtual machine installed on my MAC, it works well.

The issue was also sent to Dutch&Ducth (Martijn).

Thank you for your help John.
 
Top Bottom