Using REW to verify AL correction

Iainmc

New Member
Thread Starter
Joined
May 30, 2017
Messages
4
My AV System  
Preamp, Processor or Receiver
PC
The filters created in AL are used in the Jriver convolver and everything is working fine. When I do a measument of left and right chanels combined at the listening position I get this result,
54899

The amplitude resonse is very close to the simulated resonse in AL but the phase response is not as expected, minimum phase. and the group delay is off.
54905

If I apply a frequency dependat window, REW default, I get this result. Changing the window size still gives similar results.
54906

The phase result is now as expected but the freqency response has worsened. The group delay is now as expected.
54907

So the question is, what is the correct processing of the raw measurment to verify that the AL corrections are working as intended?
 

juicehifi

Audiolense
Staff member
Joined
Feb 5, 2018
Messages
517
I would disregard phase and group delay, and look at the frequency response and the shape of the impulse … and perhaps the step response too.
 

Iainmc

New Member
Thread Starter
Joined
May 30, 2017
Messages
4
My AV System  
Preamp, Processor or Receiver
PC
Thank you for your reply.
Can you please explain why the phase and group delay measurments should be disregarded? Just trying to understand.
 

juicehifi

Audiolense
Staff member
Joined
Feb 5, 2018
Messages
517
Phase displays such as the one above does not tell me a lot about the time domain behavior. This is my personal opinion, others may disagree.

I use a combination of group delay and magnitude to spot for problem frequencies, though. Group delay peak and magnitude dip at the same frequency = acoustic trouble, usually not worth trying to time correct.
 
Top Bottom