REW macOS DMG (includes private Java 8 JRE)

REW Beta Release REW macOS DMG (includes private Java 8 JRE) V5.20 pre release

You Must Login or Register to Download

pinox67

New Member
Joined
Sep 21, 2019
Messages
11
Location
Italy
My AV System  
Preamp, Processor or Receiver
Anthem AVM60
Main Amp
Nad M27
Universal / Blu-ray / CD Player
Sony X1000es
Front Speakers
Focal Aria 936
Center Channel Speaker
Focal Aria 900 CC
Surround Speakers
Focal Aria 906
Front Height Speakers
Focal Dome Flax
Subwoofers
2 x B&W pv1d
Video Display Device
Sony 55 AG8
Other Equipment
RME adi2 pro fs
I think I found the cause of this. It appears to be a side-effect of the workaround to cope with format or sample rate changes being made in Audio Midi Setup while REW is running, but would only occur for interfaces that show both inputs and outputs in a single entry in Audio Midi Setup and when the generator was started before the RTA. I'm guessing that CoreAudio actually starts input and output for those interfaces when the generator starts (there is a prompt to allow mic access on starting the generator) which triggers the issue. All appears to be OK if the RTA is started first. I have disabled the Audio Midi Setup change workaround in beta 61.
I’ve tried the same measurements with the last release. Great! All works fine now.
Thank you very much for your prompt resolution :cool:
 

sam_adams

New Member
Joined
May 23, 2017
Messages
10
There doesn't seem to be a way to alter the CoreAudio buffer size through the OS. but applications can alter it. There is a mention here of using LogicX to alter the buffer size and that change applying globally, and Native Instruments have a set of mac recommendations and tips here. Strange that my old Mac mini works without issue, but perhaps the OS uses a larger default buffer size for older hardware. I may be able to add a setting to the info.plist to encourage the OS to use a larger buffer size, I will look into that.
I tried those tips in the second link at the time, also. Those didn't solve the issue either. Many years ago DigiDesign used to include a Core Audio Manager in ProTools to adjust those values. Sadly, it was not a standalone program.
 

elijahscott1982

Registered
Joined
Mar 7, 2019
Messages
2
I cant seem to get Mac to load this says error for java. Im on the newest 10.15.7 software. Everything was working yesterday after I updated my computer now it won't load. What else can I try?
 

John Mulcahy

REW Author
Thread Starter
Joined
Apr 3, 2017
Messages
3,592
I cant seem to get Mac to load this says error for java. Im on the newest 10.15.7 software. Everything was working yesterday after I updated my computer now it won't load. What else can I try?
Could try uninstalling and reinstalling REW. There is an uninstaller in the REW folder in Applications.
 

elijahscott1982

Registered
Joined
Mar 7, 2019
Messages
2
Could try uninstalling and reinstalling REW. There is an uninstaller in the REW folder in Applications.
tried multiple times it won't instal and gives me a error file that shows this.

Exception:

java.lang.RuntimeException: java.lang.NoClassDefFoundError: com.install4j.runtime.beans.screens.SystemFormScreen
at com.install4j.runtime.installer.frontend.GUIHelper.invokeOnEDT(GUIHelper.java:750)
at com.install4j.runtime.installer.config.AbstractBeanConfig.finishBatch(AbstractBeanConfig.java:54)
at com.install4j.runtime.installer.ContextImpl.registerScreens(ContextImpl.java:732)
at com.install4j.runtime.installer.controller.Controller.start(Controller.java:94)
at com.install4j.runtime.installer.Installer.runInProcess(Installer.java:61)
at com.install4j.runtime.installer.Installer.main(Installer.java:46)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at com.exe4j.runtime.LauncherEngine.launch(LauncherEngine.java:84)
at com.install4j.runtime.launcher.MacLauncher.main(MacLauncher.java:52)
Caused by: java.lang.NoClassDefFoundError: com.install4j.runtime.beans.screens.SystemFormScreen
at java.lang.Class.getDeclaredMethods0(Native Method)
at java.lang.Class.privateGetDeclaredMethods(Class.java:2701)
at java.lang.Class.privateGetPublicMethods(Class.java:2902)
at java.lang.Class.getMethods(Class.java:1615)
at com.sun.beans.finder.MethodFinder$1.create(MethodFinder.java:54)
at com.sun.beans.finder.MethodFinder$1.create(MethodFinder.java:49)
at com.sun.beans.util.Cache.get(Cache.java:126)
at com.sun.beans.finder.MethodFinder.findMethod(MethodFinder.java:81)
at java.beans.Statement.getMethod(Statement.java:357)
at java.beans.Statement.invokeInternal(Statement.java:261)
at java.beans.Statement.access$000(Statement.java:58)
at java.beans.Statement$2.run(Statement.java:185)
at java.security.AccessController.doPrivileged(Native Method)
 

Chuck Zwicky

Registered
Joined
Sep 8, 2017
Messages
36
Hi John,

Having some problems with the scope function.. it worked once, but the trigger point kept jumping around in the trigger settings menu..

I could not get it to work until I rebooted several times, but eventually it just stopped working at all..
Screen Shot 2020-10-09 at 10.10.28.jpg



ALSO:

The beta install is somewhat suspect:
Screen Shot 2020-10-09 at 10.17.24.jpg
 

John Mulcahy

REW Author
Thread Starter
Joined
Apr 3, 2017
Messages
3,592
tried multiple times it won't instal and gives me a error file that shows this.

Exception:

java.lang.RuntimeException: java.lang.NoClassDefFoundError: com.install4j.runtime.beans.screens.SystemFormScreen
I just tried updating to 10.15.7, REW worked normally afterwards so not sure what can have happened. May be worth opening a terminal window and typing printenv to see if there are any Java-related environment variables listed, something may have persisted from 10.15.6 that needs to be set differently for 10.15.7.
 

John Mulcahy

REW Author
Thread Starter
Joined
Apr 3, 2017
Messages
3,592
Hi John,

Having some problems with the scope function.. it worked once, but the trigger point kept jumping around in the trigger settings menu..
I think I have fixed that for the next beta. Java on MacOS has some odd behaviours on value changes that can be difficult to deal with.

The beta install is somewhat suspect
In what way is it suspect? V5.20 is a folder application for ease of access to the uninstaller, which allows preferences to be deleted when uninstalling if desired - that wouldn't happen with an application bundle.
 

SRLive

Registered
Joined
Jan 8, 2020
Messages
1
My AV System  
Preamp, Processor or Receiver
Focusrite Saffire -
Hi, I'm trying to update my old beta 45 on Mojave and still struggle to get past the license agreement. I remember I had this issue and don't remember what I did to install the old one... I disabled every manager light better snap tool, bartender, my UPDD daemon and the accessibility preferences, still no success.

EDIT : well, it got past. Just had to wait more than 10 minutes but it finally got it done while looking frozen...
Sorry for the unusefull post
 
Last edited:

John Mulcahy

REW Author
Thread Starter
Joined
Apr 3, 2017
Messages
3,592
John Mulcahy updated REW macOS DMG (includes private Java 8 JRE) with a new update entry:

REW V5.20 pre release macOS DMG

This is the pre-release of V5.20, changes compared to the last beta are:
  • Enabled the Pro upgrades menu (note that the miniDSP UMIK-X multichannel mic array includes a pro upgrade license)
  • Append "SPL Logger" to window title for SPL Logger to distinguish it from SPL meter title
  • Bug fix: DCX equaliser setting had 6th order BU and LR filters, they should be 8th order
  • Bug fix: If the...
Read the rest of this update entry...
 

pinox67

New Member
Joined
Sep 21, 2019
Messages
11
Location
Italy
My AV System  
Preamp, Processor or Receiver
Anthem AVM60
Main Amp
Nad M27
Universal / Blu-ray / CD Player
Sony X1000es
Front Speakers
Focal Aria 936
Center Channel Speaker
Focal Aria 900 CC
Surround Speakers
Focal Aria 906
Front Height Speakers
Focal Dome Flax
Subwoofers
2 x B&W pv1d
Video Display Device
Sony 55 AG8
Other Equipment
RME adi2 pro fs
Hi John,
I've just downloaded V5.20 prerelease on my MacBook Pro (Catalina 10.15.6).
I've found these problems (I don't known if they are already present in the previous releases):

1. Scope:
It seems it has the same sync problems of RTA that I summarised in my previous post: sometime it shows something but others, with the same input by Signal Generator, it does not show nothing. The sound card is the RME Adi2 pro, set at 192KHz.

2. RT60 Decay:
When I move the mouse left and right (also very slowly) in the waterfall to see dynamically "a section" of it in the upper diagram, very often REW stops working (or it becomes very very slow) after some time (one minute or less). I've to force quit to exit. I suspect it is connected to memory usage.

And a suggestion:
Like in the Signal Generator window there is the possibility to select the output channel(s), it would be useful if there was in the RTA window the possibility to select the input channel.

Regards,
Pino
 
Last edited:

John Mulcahy

REW Author
Thread Starter
Joined
Apr 3, 2017
Messages
3,592
tried multiple times it won't instal and gives me a error file that shows this.

Exception:

java.lang.RuntimeException: java.lang.NoClassDefFoundError: com.install4j.runtime.beans.screens.SystemFormScreen
The good folk at ej technologies, who make the installer, believe the problem is due to this Java runtime bug: Docked MacBook cannot start any Java Swing applications. If that is the case then it may work if undocked, or if REW is started before docking. As a more permanent solution I have made a test build that uses a more recent JRE that hopefully does not have this bug. It is a larger download, as the JRE has some features REW doesn't use, but otherwise it should work. It is available here: REW macOS JRE test
 

John Mulcahy

REW Author
Thread Starter
Joined
Apr 3, 2017
Messages
3,592
2. RT60 Decay:
When I move the mouse left and right (also very slowly) in the waterfall to see dynamically "a section" of it in the upper diagram, very often REW stops working (or it becomes very very slow) after some time (one minute or less). I've to force quit to exit. I suspect it is connected to memory usage.
I have tracked down the cause of that and updated the macOS JRE test build linked in the previous post with a fix, please try that version.
 

Chuck Zwicky

Registered
Joined
Sep 8, 2017
Messages
36
Latest Beta has some triggering issues in the scope under OSX (see attached video

 
Last edited by a moderator:

John Mulcahy

REW Author
Thread Starter
Joined
Apr 3, 2017
Messages
3,592
Auto disengaged:
The hysteresis is a bit high but that is odd behaviour. Is it specific to that signal? If you feed in a square wave from the generator do you get consistent triggering? What is the sample rate, and is REW set to the same rate as the interface?
 

Chuck Zwicky

Registered
Joined
Sep 8, 2017
Messages
36
Yes the interface and REW were both set to the same rate.. I played with the trigger threshold and hysteresis no no avail, almost looks like a clocking or buffering issue. Will try a lower sample rate...
 

pinox67

New Member
Joined
Sep 21, 2019
Messages
11
Location
Italy
My AV System  
Preamp, Processor or Receiver
Anthem AVM60
Main Amp
Nad M27
Universal / Blu-ray / CD Player
Sony X1000es
Front Speakers
Focal Aria 936
Center Channel Speaker
Focal Aria 900 CC
Surround Speakers
Focal Aria 906
Front Height Speakers
Focal Dome Flax
Subwoofers
2 x B&W pv1d
Video Display Device
Sony 55 AG8
Other Equipment
RME adi2 pro fs
I have tracked down the cause of that and updated the macOS JRE test build linked in the previous post with a fix, please try that version.
Hi John,
With JRE test RT60 Graph now works well, without any block, very good!
I've to test now the Scope with some measures.
Pino
 
Top Bottom