REW latest beta on Mac OS only uses internal mic

SpoOokY

New Member
Thread Starter
Joined
Feb 9, 2019
Messages
2
Hi there,

I have just downloaded the latest beta and tried ist with my Umik-1 on the latest Mc OS version. During startup REW recognizes the Umik and asks for a calibration file. In the settings the Umik ist selected in REW and Mac OS. In the Mac OS Sound settings I can clearly see that the Umik is working properly. However, REW does only use the internal microphone no matter what I have selected.
Is there anything I am missing or I did wrong?

Thanks a lot for your help!
 

John Mulcahy

REW Author
Joined
Apr 3, 2017
Messages
1,897
Could you attach the soundcard debug file with the UMIK connected, please? It is generated using the button on the Soundcard preferences.
 

HU the wood

New Member
Joined
Feb 4, 2019
Messages
1
Hi guys,
I just changed to the Beta version today and detected the same problem concerning use of internal mic only. A few minutes ago I got an update notice for Mojave 10.14.3 - after the Mac restart this seems to have settled this problem with the mic. Please check.
best regards
Walter
 

Petter

New Member
Joined
May 1, 2019
Messages
4
I have the same issue with both v5.19 and v5.20 beta 9. Running Mojave 10.14.4.
 

John Mulcahy

REW Author
Joined
Apr 3, 2017
Messages
1,897
Can you post a screenshot of the Audio Midi Setup app Petter? It is in Applications > Utilities.
 

John Mulcahy

REW Author
Joined
Apr 3, 2017
Messages
1,897
Are you using a UMIK or something else, Petter? A UMIK should appear as "Umik-1 Gain: 18 dB". Can you also show a screenshot of your REW soundcard preferences?
 

Petter

New Member
Joined
May 1, 2019
Messages
4
Are you using a UMIK or something else, Petter? A UMIK should appear as "Umik-1 Gain: 18 dB". Can you also show a screenshot of your REW soundcard preferences?
I'm using the Dayton Audio EMM-6 with a USB dongle/soundcard thingy to provide phantom power.
I've also tried using Dayton Audio iMM-6 which is just a regular mic using the minijack input/output on the mac.
 

Attachments

John Mulcahy

REW Author
Joined
Apr 3, 2017
Messages
1,897
Best select 48k in REW, same as the Audio Midi Setup setting. Shouldn't make any difference but keeping them the same avoids resampling in the OS.

Is there an option other than "Default input" for the input selection? If so, try selecting that.

As a final attempt could try leaving the input device set to Default device (since the external mic is selected as the macOS input anyway) and see if that works any better.

I'm none the wiser about what could be causing this, beyond the possibility of a bug in the macOS JavaSound layer. The REW code is the same for Windows, Linux and macOS and I haven't seen reports of anything similar on the other platforms, it is a tricky one to understand.
 

Petter

New Member
Joined
May 1, 2019
Messages
4
Tried all sampling rates, and combinations of input and output selections already :) I tried with High Sierra on another partition, and everything works fine there btw.
 

John Mulcahy

REW Author
Joined
Apr 3, 2017
Messages
1,897
That does suggest there is some OS-level factor at play. Are there any other audio (or comms, e.g. Skype) applications running which might be requesting access to the internal mic? That might be enough to confuse things, when mixed up with the Mojave mic privacy control mechanisms.
 

John Mulcahy

REW Author
Joined
Apr 3, 2017
Messages
1,897
There was also this comment from Karsten on the other thread:
While playing around I stumbled across "deleting prefs" in REW and tried so. After that I was able to make the orange measurement, which looks plausible to me. Interestingly this state doesn't last long. As soon as I switch over to the internal mic and than back to the UMIK, again only the internal MIC is used. Until I delete prefs again and start from scratch.
Deleting the prefs sets REW back to using the default input and output. If nothing else gets selected that may continue to provide the input selected in Audio Midi Setup.
 
Top Bottom