REW Beta Release Linux sound almost works...

Discussion in 'Official REW (Room EQ Wizard) Support Forum' started by keantoken, Feb 3, 2019.

  1. keantoken

    keantoken Member
    Thread Starter

    Joined:
    May 31, 2018
    Messages:
    21
    Likes Received:
    0
    Question, is there anyone who uses REW on Linux? If so, what Java version do you use, do you use any extra Java libraries?

    The sound started working with the latest beta, after flipping some options.

    The problem is, REW is not passing the correct samplerate to the audio drivers. Higher samplerates just play at a lower pitch. Furthermore, when I increase the buffer, REW doesn't account for the extra latency (perhaps just a side effect).

    I've attached the soundcard debug file. It seems there is a problem obtaining the samplerate.
     

    Attached Files:

  2. keantoken

    keantoken Member
    Thread Starter

    Joined:
    May 31, 2018
    Messages:
    21
    Likes Received:
    0
    I tried it again. This time, it seems to have successfully changed to 96KHz early on and then afterwards that was the only setting that worked.
     
  3. keantoken

    keantoken Member
    Thread Starter

    Joined:
    May 31, 2018
    Messages:
    21
    Likes Received:
    0
    When I first start REW, sound doesn't work. Just a blip of sound right after stopping the check level function. If I go to "set channel output mapping" -> "reset mapping", sound will start working.
     
  4. keantoken

    keantoken Member
    Thread Starter

    Joined:
    May 31, 2018
    Messages:
    21
    Likes Received:
    0
    Oops, strike that. What I actually did was change the output channel to R, then back to L. I don't think the channel mapping reset had an effect.
     

Share This Page