Failing to install on MacOS Ventura Dev Beta

R3k

Registered
Thread Starter
Joined
Sep 20, 2022
Messages
1
Hi. Just a heads up, the REW installer seems to be broken on my test system here. Running the latest developer Beta of MacOS Ventura on a Mac Studio M1 Ultra.

The installer starts to launch and a window appears saying that it's preparing to install. That window disappears in a moment and the installer just stops with no windows on screen. My Dock still shows the installer icon and names it 'java' but there are no on screen windows to interact with. "REW Installer" is not hanging inside the application switcher.

It's almost like 'java' is requiring some sort of interaction from me but MacOS is blocking it from querying me.

I can see no entries in macOS's security / privacy settings that have holding things up.

I can still use my older (pre Ventura installed) version of REW so all good there.

Cheers
 

fattire

New Member
Joined
Jan 30, 2021
Messages
18
@John Mulcahy - I'm having this issue as well. 2021 14" M1 MBP. I did a fresh install of the final version, not an upgrade, of MacOS 13 (Ventura). I get behavior identical to R3k's above with both 5.20.13 and the 5.20.14 early access versions.
 
  • Like
Reactions: R3k

fattire

New Member
Joined
Jan 30, 2021
Messages
18
I see new builds / releases and will try those later today.

I wanted to drop a note that I was able to get 5.20.3 installed with no issue on Ventura. Upgrades still had the same problem.
 

John Mulcahy

REW Author
Joined
Apr 3, 2017
Messages
6,041
It was an installer bug when the mac was in dark mode, it got fixed in the latest installer release.
 

fattire

New Member
Joined
Jan 30, 2021
Messages
18
Confirming the issue is resolved in the latest 5.20.14 build. Thank you, sir!
 
Top Bottom