ASIO issues after update to V5.20 RC9

BJB

New Member
Thread Starter
Joined
Mar 5, 2020
Messages
16
I think this should probably be a separate post vs. an update process question which was answered.

My old beta build was rock solid with ASIO and HDMI output and my Umik input settings...,once I got them working they stayed working.

I took a snip of my ASIO settings that worked before my upgrade on my old build so I knew what it needed to look like.

I then upgraded to V5.20 RC9 which I installed in a separate folder from my old version. After the upgrade I knew to "turn on" the arrow for Intel HD and sure enough it worked, I had HDMI input choices and the test sweep worked! But although windows and the panel recognized my Unik microphone, it now didn't show in the input drop down. Then I could get the Unik to show but then immediately my HDMI output would go away!

After a lot of back and forth and ASIO refreshing I did get both working.

So I can get them working and if I leave the program up it seems to stay working. But when I close REW, then re-open, I have to go through the same thing to get both working again. Not the end of the world but wondering if there is a way to make the settings "sticky".

I searched on ASIO in the forum and did not see any recent posts with this particular issue but I know I am coming from an older version, beta 46.

Should I be updating ASIO4all? I hesitate to touch anything with ASIO as I know it can be finicky...

Thanks,
BJB
 

John Mulcahy

REW Author
Joined
Apr 3, 2017
Messages
4,460
I'm not following which drop down you are referring to when you say the UMIK did not show up. Perhaps some screenshots of what you see at the various stages would help.
 

BJB

New Member
Thread Starter
Joined
Mar 5, 2020
Messages
16
Sorry, I am not with my REW laptop right now but these are the two drop downs I am talking about on attached snip from the help file.
REW.jpg
When HDMI output is working I can choose HDMI 1 through 6 from left.. when input is working the UMIK microphone is listed on the right.
One or the other worked until finally they both did. By worked I mean hdmi listed on left and UMIK available to choose on the right.

Thanks,
BJB
 

BJB

New Member
Thread Starter
Joined
Mar 5, 2020
Messages
16
@John Mulcahy ,
I am sure you have been busy with the release but let me know if you need anything else on this. I was going to try RC10 nd see if there was any change.

Got hungup with multiple windows updates this weekend so couldn't get back to it... :)

Thanks,
BJB
 

John Mulcahy

REW Author
Joined
Apr 3, 2017
Messages
4,460
There isn't really anything I can do about that. The options in the dropdowns are what the ASIO driver says are available. If you subsequently make changes in the ASIO control panel it is necessary to reload the driver using the button on the REW soundcard preferences for REW to find out what has been changed.
 
  • Like
Reactions: BJB
Top Bottom